5 votes

Broken Thumbnail(Favicon) Images for External Links

I'm wondering if others are seeing as many "broken" thumbnail(favicon) images to the left of externally linked posts? I'm not sure if it's simply because my browser needs to have visited a site before it will show me the website's default favicon or something else? For example please see below:

Favicon missing

Apologies if this has already been asked/addressed.

Edit: I just tested visiting the site linked and then reloading Tildes and it doesn't update so I assume it's probably on the external site's "end".

6 comments

  1. [6]
    Bauke Link
    They're not broken, just not all of the icons are in the "site-icons" image. So only a number of predefined icons will show up. https://tildes.net/css/site-icons.css...

    They're not broken, just not all of the icons are in the "site-icons" image. So only a number of predefined icons will show up.

    Edit: I made an issue for it, as there wasn't any before.

    8 votes
    1. [5]
      PlatoLake Link Parent
      Thank you for the information and creating the issue on gitlab. That makes much more sense. A manual list like this will be a nightmare to maintain.

      Thank you for the information and creating the issue on gitlab. That makes much more sense. A manual list like this will be a nightmare to maintain.

      3 votes
      1. [2]
        cfabbro Link Parent
        The plan is to use a metadata scraper to grab the favicons (amongst other things)... it's just not in place yet.

        The plan is to use a metadata scraper to grab the favicons (amongst other things)... it's just not in place yet.

        3 votes
        1. PlatoLake Link Parent
          Great! Thanks for the info!

          Great! Thanks for the info!

          1 vote
      2. [2]
        Deimos Link Parent
        It's supposed to be automatic. It had some issues so I disabled it for now and haven't gotten back around to fixing it up yet.

        It's supposed to be automatic. It had some issues so I disabled it for now and haven't gotten back around to fixing it up yet.

        2 votes
        1. PlatoLake Link Parent
          Thanks again for all you do!

          Thanks again for all you do!

          1 vote